1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Hail Guest Stratics will be brought down at 12 p.m. EST on Janury 8th in order to preform a server migration and updates to our software. Please read this post for details: REMINDER MAINTENANCE TOMORROW 12 P.M. EST [NOON EST]
    Dismiss Notice

Second Life on Linux

Discussion in 'Second Life Discussions' started by Katheryne, Aug 31, 2008.

  1. Katheryne

    Katheryne Guest

    As you may or may not be aware, the Second Life viewer is available for Linux, negating the need to run the Windows version from within WINE. It is not, however, without its problems. Voice chat, for example, is very dicey.

    Are you running Second Life from within Linux? If so, then please share your experiences. What Linux distro are you using (Debian, Mint, Ubuntu, etc.)? What desktop management are you using (Gnome, KDE, etc.)? Are you running a 32-bit or 64-bit version of Linux? What audio server setup are you using (OSS, ESD, ALSA, PulseAudio, etc.)? Do you have problems with voice chat? With streaming music or media? Other issues?

    I would like to make this an SL-Linux support thread. I don't have all the answers, but between all of us, I'm sure we can come up with answers to help each other and anyone else who encounters a problem.

    So, here goes:

    I run Ubuntu x64, using Gnome. I have PulseAudio set up, with ESD-emulation (pulseaudio-esound-compat) and OSS redirection through padsp. However, in spite of all the workarounds I have tried, I have no voice capability. It doesn't even attempt to connect to the vivox servers. Additionally, attempting to access streaming media causes me to crash, with both the v1.19.1.4 and v1.20.15 viewers. I have every gstreamer codec and plugin available, but no dice. When it crashes, it doesn't even leave a clue about what happened in the crash logs. Streaming music works fine.

    I am beginning to believe that the voice problem is due to 64-bit incompatibility. I was able to establish connection using my 32-bit Ubuntu server box, but it would disconnect/reconnect every 60 seconds, and I could not hear anyone. I did not try any of the workarounds there because I did not want to corrupt my server. I may replace my 64-bit install on my laptop with the 32-bit version when Intrepid Ibex comes out in about two months, and we'll see what happens then.

    The crashing when accessing streaming media problem is still a complete head-scratcher for me.

    Lastly, when using the v1.20.15 viewer, I experience frequent freeze-ups that require me to reset my wireless card to fix. Everything will be working fine for a while, and then all of a sudden things get stuttery, the viewer freezes for a second, and my wireless card goes offline. Anyone else experience this problem?
  2. Katheryne

    Katheryne Guest

    There is a fix in progress for the SLVoice problem. Someone was able to do a backtrace of the SLVoice module - the results of which caught both Linden's and VIVOX's attention. A new voice module is in the works and should show up in the next Windlight full release. In the meantime, there is a workaround to get voice working, and it's ridiculously easy:

    Using your favorite text editor (gedit or kate, or VIM for you hard-core folks), create the following script:
    #! /bin/sh  
    sed 's/:$/: /g' /proc/cpuinfo > cpuinfo  
    cp libvivoxsdk.so libvivoxsdk.so.bak  
    sed 's/\/proc\/cpuinfo/lib\/cpuinfo\[email protected]\[email protected]/g' libvivoxsdk.so.bak > libvivoxsdk.so
    Save it within the libs directory within your Second Life directory, as fix_cpuinfo.sh and be sure you make it executable. Then, just run the script. It will patch the defective library libvivoxsdk.so with your cpuinfo, preventing an out_of_range exception being thrown when SLVoice is started up.

    Ticket#VWR-5708 explains the technical aspects of the issue.
  3. NikiKing

    NikiKing Grand Poobah
    Stratics Veteran

    Sep 12, 2003
    Likes Received:
    YAY Kat! Does this mean we can talk to you now??
  4. Katheryne

    Katheryne Guest

    Nope; Beside the fact I don't own a mic (and am not a big fan of voice chat anyways), it looks like I spoke too soon about fixing the voice issue for SL Linux. It appears we're down to Pulseaudio or ALSA incompatibilities. I'm still playing around with the SLVoice runtime files.
  5. NikiKing

    NikiKing Grand Poobah
    Stratics Veteran

    Sep 12, 2003
    Likes Received:
    I'd be happy if you could hear us when we talk!
  6. Katheryne

    Katheryne Guest

    Yes, I'd like to be able to hear you guys too. Seeing only half the conversation gets old real quick! :p
  7. Katheryne

    Katheryne Guest

    I think I finally got it! It wasn't easy, but I finally got voice to work reliably on 64-bit Ubuntu Linux (even though I don't own a mic nor am I about to go and get one)!

    So, if you're running 64-bit Ubuntu 7.10 (Gutsy) or 8.04 (Hardy) or any other distro that uses Pulseaudio as its primary sound server, this is what you need to do to make voice work on SL (tested with viewer and

    AMD64 and i386 users (if you do not see a voice dot above your avatar in game):
    First, SLVoice needs to be patched to use an OSS-to-PA workaround. To do this, simply rename SLVoice to SLVoice.bin. Next, create a script named SLVoice. Copy the following into the script and save (mark it as executable):
    if test -x /usr/bin/padsp ; then
       exec /usr/bin/padsp ~/SecondLife_i686_1_19_1_4/SLVoice.bin "[email protected]"
       exec ~/SecondLife_i686_1_19_1_4/SLVoice.bin "[email protected]"
    This assumes you have Second Life installed in your home directory. If not, replace ~/ with the full path to your Second Life folder. This also assumes you are running viewer version If you are running any other version, replace SecondLife_i686_1_19_1_4 with the name of the folder your Second Life executable is in.

    Next, if you don't already have it, install padsp. This is the workaround patch to trick non-Pulseaudio-aware applications into using Pulseaudio:
    sudo apt-get install pulseaudio-tools
    AMD64 users:
    Next, libvivoxsdk.so needs to be patched to correct a bug that occurs when SLVoice queries your hardware configuration. To do this, open the libs folder within your Second Life folder, and create a new script there. Paste the following into this script and save it as fix_cpuinfo.sh:
    #! /bin/sh
    sed 's/:$/: /g' /proc/cpuinfo > cpuinfo  
    cp libvivoxsdk.so libvivoxsdk.so.bak  
    sed 's/\/proc\/cpuinfo/lib\/cpuinfo\[email protected]\[email protected]/g' libvivoxsdk.so.bak > libvivoxsdk.so
    Once done with this, execute the script (don't forget to set it as executable first).

    AMD64 users, and i386 users if you frequently see "Connecting to in-world voice chat" in your chat history:
    Finally, there are two other libraries that need to be replaced: libalut.so and libopenal.so.1. You will need to download a copy of viewer version, which you can get here. Delete your existing libalut.so, libopenal.so.1, libortp.so, and libvivoxsdk.so files. Untar the downloaded file, and navigate to SecondLife_i686_1_19_0_5/lib, and copy the four above files into your Second Life /libs directory. Re-apply the fix_cpuinfo patch if you are running 64-bit.

    Finally, launch Second Life as you normally do, open your Preferences, go to Voice, and - in Device Settings - ensure both pull-downs are set to "Open Sound System (OSS)".

    You should finally have working voice! If you don't, then there is another version of libopenal.so.1 you can try. Download it from here and replace your existing libopenal.so.1 in your Second Life /lib folder.

    As for crashing when attempting to play streaming media, this is unfortunately unique to 64-bit users, as Second Life cannot make use of the 64-bit version of gstreamer and its libraries. Second Life will inform you of this if you look closely at the logs, but poor error trapping still results in the viewer throwing a segmentation fault exception and crashing when encountering in-game video. The only way to fix this is to somehow wedge 32-bit gstreamer libraries into your system, but this may introduce more problems than it's worth. I am still figuring out a workaround for this issue.
  8. Masami

    Masami Guest

    Ubuntu, currently 8.04.1.

    Gnome, without desktop effects.


    The SL viewer is using ESD here. SLvoice is using ALSA. I removed PulseAudio because there were too many issues with it.

    None at all. It worked for me since day #1. I'm using it frequently.

    There are some issues with streaming media. If there is an Ogg Vorbis audio stream assigned to a parcel, the viewer is unable to play it back. Some rare video formats and transport protocols don't work well either. The embedded web browser can't handle pages with Flash. Fortunately it's easy to open these streams and pages in external applications, so the issues don't affect me too much. I am very content with the current state of SL on Linux. Crashes have become very rare since v1.20. Recently I've been testing OpenSim. I think OpenSim grids are the future of SL.
  9. Katheryne

    Katheryne Guest

    Yeah, I tried removing Pulseaudio, and while SL worked somewhat, I ran into other system-wide problems, like system sounds not working anymore (seems that since 7.10, these are hard-coded to PA). The best solution for me was to keep Pulseaudio, force OSS calls to Pulseaudio using padsp, and set voice chat to use OSS - and using the Vivox runtime libraries from viewer FMOD (the audio runtime SL uses for everything except voice) plays quite nicely with Pulseaudio. However, Vivox needs to wake up and realize that Linux is evolving.

    On another note: Since Linden Labs has made updating from viewer versions and 1.20.2.x mandatory, Linux users with nVidia graphics cards may need to change the installed graphics driver. The 169-series drivers that normally install with Ubuntu (nvidia-glx-new) have known issues with the newer Windlight viewers that causes frequent systemwide freezes and breaks your network connection. Uninstalling nvidia-glx-new and installing nvidia-glx-new-envy installs a 173-series driver that works perfectly.

    Related to that, the newest viewer version, 1.21.5.x, which includes the security update, is now available as a release candidate. I suggest giving it a try. I've been using it exclusively (with the CoolSL Viewer patches available here)for the past week, and it has been running perfectly stable for me.

    Masami: I haven't encountered any OGG streams in SL yet, but if you're having issues with those, I suggest ensuring you have all the gstreamer plugins installed - good, bad, and ugly. The OGG codecs should be part of the good package, but the others will give you greater compatibility with other media types that may be used within SL. This is especially true for Quicktime videos, which seem to be in heavy use. The Quicktime codec is part of the ugly package.
  10. Katheryne,

    Hello, and thank you for the information you've posted so far. I am running SL on Hardy as well, and I have followed your procedures above, but I still am unable to get voice chat to function. One thing that I did notice is that my drop down menus in the device settings only have 'default' - there is no other value, so I can't set them explicitly to ALSA as you indicated. Any thoughts? Thanks again.

  11. Katheryne

    Katheryne Guest

    It sounds like one of two things: Either something else on your system is using OSS and therefore it's not available for SLVoice (since OSS does not have mixing capability), or there is a library incompatibility.

    First, go to your Sound control panel on your desktop (in the Preferences menu for Gnome) and ensure nothing is set to use OSS. It's probably best to set everything to PulseAudio rather than leave them at Autodetect.

    If this doesn't solve the problem and make OSS available to SLVoice, then you will need to go back to that one download I mentioned (Viewer version, and extract these two libraries to your Second Life libs folder: libortp.so and libvivoxsdk.so. Make certain that your libalut.so and your libopenal.so.1 libraries have come from there as well.

    The reason I specifically mention OSS here is because SLVoice's ALSA support is broken. It will cause repeated connects and disconnects. Since SLVoice does not directly support PulseAudio or ESound, this leaves OSS as the only available system it will work with.
  12. Katheryne

    Katheryne Guest

    Well, so... It's been a rather, errrm - interesting month so far! I got my laptop back last week after it had spent two weeks in the shop when the video processor died - only to find that it is HP's policy to re-image the hard drive regardless of the reason the computer was sent in for repair! So, I had to repartition the drive, reinstall everything, and reinstall Linux (because Second Life under Vista is a fate I wouldn't wish on my worst enemies). As luck would have it, Ubuntu 8.10 (Intrepid Ibex) had just been released, so I took advantage of my situation and did a clean install of Intrepid.

    *pauses to take in Intrepid's awesomeness*

    There was one down side, however: My earlier tricks to get voice working in Second Life no longer worked - at least, not on my setup. Every indication I was getting was that the voice client properly connected to Pulseaudio, was connecting to Vivox, but was not registering my connection. Something somewhere in Ubuntu's configuration had changed between Hardy and Intrepid, and I didn't know what; but I suspected SIP support had changed (SIP is a voice-over-internet protocol used by common VoIP applications such as Skype and SLVoice).

    Anyways, I didn't have too much time to ponder over this, as, in what I can only describe as perfect timing, Tofu Linden (Linden Labs' Linux guru) posted a new experimental viewer to the SL forums, with the disclaimer that it is experimental and considered to be in alpha state. That fact certainly shone through when I tried it, but that's not important. What is important, however, is that this viewer included updated Vivox runtime files. Vivox finally released a version of SLVoice that plays nice with Pulseaudio.

    Well, sort of.

    After playing around with the experimental viewer and deciding it wasn't ready for the real world yet, I went to work playing with the Vivox runtimes. What I came up with is a solution that finally allows SLVoice to work without having to resort to OSS, and, more importantly, to work on Intrepid. But there's a catch. The catch is that the new runtimes occasionally causes Pulseaudio to hang, generally requiring a reboot to fix.

    However, if being able to speak or hear what other people are saying is important to you, then this is what you must do:

    First, download the experimental viewer, which you can find at the top of this thread in the Second Life forums. Unpack the tarball somewhere.

    Next, go into the unpacked tarball, copy the following files, and replace the files in your existing Second Life folder:

    • /bin/SLVoice
    • /lib/libalut.so
    • /lib/libortp.so
    • /lib/libopenal.so.1
    • /lib/libvivoxsdk.so
    Please note: You will be replacing the files in your existing SL installation with the files from the experimental viewer you just unpacked.

    Also note: If you currently have the file /bin/SLVoice.bin from the earlier SLVoice fix, you may delete it. It is no longer needed.

    Next, libvivoxsdk.so needs to be patched to correct a bug that occurs when SLVoice queries your hardware configuration. To do this, open the libs folder within your Second Life folder, and create a new script there. Paste the following into this script and save it as fix_cpuinfo.sh:
    #! /bin/sh
    sed 's/:$/: /g' /proc/cpuinfo > cpuinfo  
    cp libvivoxsdk.so libvivoxsdk.so.bak  
    sed 's/\/proc\/cpuinfo/lib\/cpuinfo\[email protected]\[email protected]/g' libvivoxsdk.so.bak > libvivoxsdk.so
    Intrepid users: This needs to be done whether you are using the 32-bit or 64-bit version of Ubuntu.
    Hardy users: This should only need to be done if you are using the 64-bit version of Ubuntu.

    Don't forget to make this new script executable. You can do this by right-clicking on the icon, selecting "Properties", going to the Permissions tab, and checking "Allow executing file as a program".

    Next, run the fix_cpuinfo.sh script you created by double-clicking the icon and selecting "Run" when prompted.

    Finally, launch Second Life, go into the preferences, and ensure your device settings under the Voice tab are set to "Advanced Linux Sound Architecture (ALSA)" or "Default". Log in, and enjoy!
  13. Katheryne

    Katheryne Guest

    I am happy to report that the latest release candidate (, aka RC8) marks a significant improvement for Linux users! The Vivox voice modules and the viewers audio engines have been completely redesigned!

    A few key improvements in RC8 that should migrate to the official release:

    • The "fixcpuinfo" hack is no longer required. The issue that was segfaulting the SLVoice binary has been fixed.
    • The "padsp" hack to force voice to use OSS is no longer required. SLVoice now works beautifully with Pulseaudio with no modifications needed.
    • SL's audio engine now uses OpenAL instead of fmod. The result is sound that is clearer (and, dare I say, louder) than before, and positional sound (that is, sound that moves around as you do) seems more refined.
    Reviewing some of the issues raised in the support forums regarding this RC, it seems that Debian-based Linux users (Debian, Ubuntu, Mint, etc.) are most likely to see (or hear) improvements with this release. Gentoo and Slackware users still report issues. If your distro uses Pulseaudio, then you are likely to see the most significant improvements, such as voice working right out of the box.

    One important thing to note: If you currently have a solution that works, and find that RC8 (or whatever makes it to final release) breaks audio functionality, fmod is still available as a fallback. This means that the old method of rendering and routing sound will still be there, but you will need to edit the /secondlife file, uncommenting the line to avoid OpenAL.

    Lastly: OpenAL uses GStreamer 0.10 or later. You will need to have GStreamer installed and verified working before using this RC or any release based on it. Also, the problem SL has with 64-bit GStreamer still exists. If you are running a 64-bit version of your distro, you will likely lose all audio, and not just streaming media. If you find yourself in this situation, then the easiest course of action is to edit the /secondlife file to force the use of fmod.
  14. yep
    OpenGEU 8.10 ...cos i personally think its fab ... but the relevant stuff for my question is the same for Ubuntu. I am very happy with my Linux computer, but I have no deep understanding of my chosen OS.

    (kinda compiz for Enlightenment.)

    32 me thinks

    Pulse (default ubuntu intrepid one)

    Not tried it recently, messed up my system before trying...so feel my fingers burned :)

    i posted the below recently both on the Ubuntu and official sl forums but no answer yet

    ..I wonder if anyone here can suggest a tip

    ...fairly regularly i get thrown off/crash...when I re log usually my
    streaming sound (listening) is grayed out and it takes me 40 minutes of retrying
    to get the sound working for the club I was at..general i reduce my
    bandwidth to 100 and try re logging in at other places before i can
    get things to work. I do have a wobbly net connection...but other
    streaming things work ok...Zatto/BBC iplayer/Fire.Fm.

    I have nvidia card and 180.11 driver


    I am very impressed with Omviewer and appreciate the regular automatic updates. But I also use and like the other alternative viewers Cool viewer, Imprudence and Meerkat as well as the latest official viewers.

    much gratitude in advance
  15. Katheryne

    Katheryne Guest

    I use the Cool Viewer myself; haven't tried any of the other alternate viewers. I like Cool's features, so I stick with that.


    Which viewer version are you using? If you're using the Release Candidate version, then there are some steps you can try to hopefully restore streaming audio reliability:

    Open the secondlife file into a text editor. Look for this block near the top:
    ## - Avoids using any OpenAL audio driver.
    #export LL_BAD_OPENAL_DRIVER=x
    ## - Avoids using any FMOD audio driver.
    #export LL_BAD_FMOD_DRIVER=x
    Uncomment (remove the # from the front of) the "export LL_BAD_OPENAL_DRIVER=x" line. This will force the viewer to use the older but more compatible fmod audio engine instead of OpenAL. Be sure the line "#export LL_BAD_FMOD_DRIVER=x" line remains commented (has the # in front of it).

    If you are not using the release candidate version (currently 1.22 RC9), then you've got a different problem entirely. See if you can attach your logfile from ~/.secondlife/logs/secondlife.log to a reply here.

    (hint: Files and folders with a period at the beginning of the name is the UNIX/Linux way of marking the file/folder as hidden, similar to the +h attribute in Windows. To show hidden files/folders in Nautilus (the graphical file browser used in Gnome), simply press CTRL H.)
  16. Katheryne

    Katheryne Guest

    For anyone using a Linux distro that uses Pulseaudio and experiencing frequent Pulseaudio crashes while playing Second Life, there is relief on the horizon!

    I just recently upgraded my ALSA drivers and Pulseaudio server to the versions currently slated for release in Ubuntu's Jaunty Jackelope (9.04). The process was no trivial matter and I wound up making SL's audio (and system login sounds) unbearably bad, which took me a while to troubleshoot and fix.

    It turns out that OpenAL, the spacial audio engine that Second Life is turning to, has severe issues with Pulseaudio. Pulseaudio 0.9.10 (current version) eventually rolls over and dies from all the mempool issues it causes. Pulseaudio 0.9.14 (the version slated for Jaunty) doesn't die, but constantly complains about buffer underruns when playing OpenAL streams, thus causing the horrible sound quality. Tweaking a scheduler in Pulse made the problem go away, at the expense of a little extra CPU usage. But, after a ten-hour marathon session in SL, Pulseaudio remained stable; and, I might add, audio quality for both in-world sounds and voice was flawless!

    Unless you are intimately familiar with how Linux works, I do not suggest going the route I did. Either wait for these updated versions of ALSA and Pulseaudio to be backported to your distro version, or wait for the release of your distro's next version (Jaunty for Ubuntu users). If you insist on trying it now, then Google for any of the various PPAs that contain backported versions, add the PPA to your sources, and let your distro's updater handle the rest.
  17. Pedant

    Pedant Guest

    I have viewer 1.22.11 on my Ubuntu 9.04 system. Sound works, but not streaming audio or video. I am not interested in voice, just the streaming. I have the gstreamer plugins,
  18. Katheryne

    Katheryne Guest

    Are you running the x86 or x64 version of Ubuntu?

    As a short-term fix, follow the steps I posted a few posts up to force Second Life to use fmod.

    If you are using the x64 (64-bit) version of Ubuntu, then this is the best you will be able to do. fmod will get your streaming audio working, but streaming video will crash your viewer. There is no workaround.

    If you are using x86 (32-bit) version of Ubuntu, then it is possible you may not have the necessary codecs installed. Be sure you have the gstreamer plugins-base, plugins-good, and plugins-ugly packages installed. If this doesn't fix your problem, then post back.
  19. Pedant

    Pedant Guest

    x86 Ubuntu 9.04 (Jaunty)

    How do I detect those gstreamer packages? The GNOME add/remove applications panel does not use those names. I have the following:

    ffmpeg video plugin (includes mpeg)
    extra plugins (includes mp3)
    plugins for mms, quicktime

    Not the plugins for aac, xvid, mpeg2, faad, fluendo mpeg2

    All applicable updates are applied, according to the Update manager.

    The audio stream button enables, but when I click PLAY, nothing happens. Regular sounds work. It is using OpenAL and ALSA. RhythmBox has no problem streaming.
  20. Islander

    Islander Guest

    Hi, ran across this forum while looking for people with issues like I've had in linux, nice to read about other's using SL in Linux :)
    SecondLife versions being used now are (release) and (release candidate)

    Distro is Mandriva One 2009.1 (Spring) 32 bit

    Primarily I use Blackbox for a window manager, but I do have KDE 4 installed also.

    ALSA sound server - pulseaudio is installed but disabled

    Voice: The only problem I've experienced since Second Life version 1.21 is that voice will turn off from time to time. Returns to working in about a minute, and it only happens when using voice chat for typically more than 20 minutes, and waiting about a minute will bring it back to working. When it happens my 'talk' button becomes unavailable as if I've been disconnected.

    Streams: music stream seems to always work great with no issues that I can remember, but I've had some issues with video streams. Video didn't work for me at all for the longest, I started looking to correct the problems and reluctantly installed quicktime codecs, now the video portion works fine, but no audio with videos.... yet

    The machine I have is getting old... P4 dual core 3ghz. / 2 gig. / 512 mb. nVidia

    Still learning Linux, and love it more each day :D
  21. Pedant

    Pedant Guest

    I found the Synaptics package manager, and it shows I have all the gstreamer packages you mentioned.

    Here is something I found in the log. I do not know why it is trying to access the ALC devide directly rather than going through ALSA.

    2009-05-20T14:10:42Z INFO: init: LLAudioEngine::init() AudioEngine successfully initialized
    2009-05-20T14:10:43Z WARNING: init: LLAudioEngine_OpenAL::init() ALUT initialization failed: There was an error opening the ALC device
    2009-05-20T14:10:43Z WARNING: idle_startup: Unable to initialize audio engine

    The Sound Preferences control panel shows PulseAudio Sound Server selected. But the About Secont Life window says
    Audio Driver Version: (none)
    probably because of the above error initializing.

    Update: Closing RhythmBox seems to have let SL initialize its audio. It does not play well with others. But still no streaming.
  22. Pedant

    Pedant Guest

    Got music to work by uncommenting the line;
    in the secondlife shell script.

    It is now using FMOD for audio.

    Still no luck with video though. It shuts off after one second.
  23. Pedant

    Pedant Guest

    RC 1.23.2 broke it again
  24. Katheryne

    Katheryne Guest

    Quick fix: You need to disable OpenAL in the secondlife shell script every time you update viewers.

    Edit: There is an open JIRA on that issue. Check here: https://jira.secondlife.com/browse/VWR-13514. It seems (and my experience would also suggest this works in extreme cases) you might be able to fix your problem by removing the libopenal.so.1 file from ~/<path to Second Life>/lib. My recommendation is to issue the following command (assume <path to Second Life> is the exact name of your Second Life folder. Assume this folder is in your Home directory. If not, change ~/ to the exact path to your Second Life folder):
    mv ~/<path to Second Life>/lib/libopenal.so.1 ~/<path to Second Life>/lib/libopenal.so.1.old
    This will effectively remove SL's default OpenAL library without deleting it, in case you may end up needing it, and forces SL to use the distribution-installed OpenAL library.

    Now, while forcing FMOD may partially fix your problem, the best solution is to figure out your gstreamer problems and get them fixed. I am assuming you are running the 32-bit (i386) version of Jaunty. If you are running the 64-bit (x64) version, then disable OpenAL in your secondlife script and leave it at that. SL does not support the 64-bit gstreamer libraries, even with ia32 installed.

    First, open your gnome sound preferences (System -> Preferences -> Sound) and make sure everything is set to either "Autodetect" or "Pulseaudio Sound Server", except for "Device" under Default Mixer Tracks. Be sure it is set to your sound card; for example, "HDA Intel (ALSA Mixer)".

    Next, be sure that those setting have translated to gstreamer itself by opening a terminal, typing [highlight]gstreamer-properties[/highlight], and checking its settings.

    Once you have all that correct, let's verify that gstreamer works properly with MP3 streams. To do this, launch Totem. Within Totem, pull down the "Movie" menu, select "Open Location", and paste this URL into it:
    If everything is set up properly, Totem should immediately start playing that stream.

    If Totem works, but you still can't get music in SL, then you likely have an OpenAL configuration problem.

    First, make sure you have the package "libao-pulse" installed. Next, we can test OpenAL directly by typing the following into a terminal:
    mplayer -ao openal
    If this works, then you've got something wrong with your SL installation (not likely, since installing SL in Linux is extremely straightforward). If this does not work, however, then we'll need to start digging into /etc/openal/alsoft.conf. (If playing the stream worked, then you can stop playback by pressing CTRL-C or closing the terminal window).
  25. Marc Adored

    Marc Adored Guest

    I have a weird issue in this area. I can't get voice to work for me either and i have ubuntu 9.04 installed and ive downloaded the latest RC viewer used the normal viewer and my normal viewer emerald and I cant get voice to work. What I've noticed is if I start SL and go to preference before logging in and go to voice and click device settings it actually shows the sound level bar instead of just please wait... but after I log in it just stays at please wait.. and i never get the bars to test. I'm not sure if this helps and I have no way of telling what good this is to anyone capible of figuring out whats wrong but someone please help I just switched from windows 64bit back to ubuntu only i chose 64bit ubuntu this time because of the amount of ram I have now. I will note that my same configuration worked fine in ubuntu 32bit.
  26. Katheryne

    Katheryne Guest

    It's been a rather long time since I've last posted an update here, but I finally have a new one to post:

    For those of us running Linux distros with Pulseaudio "built-in" (eg. Ubuntu, Mint, and several others), most of us know how painful OpenAL support has been for Pulseaudio-enabled systems because of its flaky ALSA emulation.

    Not anymore.

    The latest version of OpenAL-Soft (currently 1.11.753) fully supports Pulseaudio. No longer does it need to run under ALSA emulation via PA to work - it now works directly with Pulseaudio. This solves a number of stability and latency issues earlier versions of OpenAL had. This means 32-bit Linux users can use OpenAL instead of FMOD for spacialized in-world audio.

    There's a catch, though.

    The version of libopenal.so that ships with the Second Life viewers is horribly obsolete. You will need to disable it and force SL to use your global OpenAL installation instead. To do this:

    1. Navigate to where your Second Life files are, then go to the /lib directory. For example, if you installed Second Life into your home directory, then it will be something like this:
      cd ~/SecondLife/lib/
    2. Locate the file libopenal.so.1 and either delete it or rename it.
    3. Ensure you have OpenAL installed on your system. For APT-based systems:
      sudo apt-get install libopenal1
    4. Make a local copy of the OpenAL configuration file:
      cp /etc/openal/alsoft.conf ~/.alsoftrc
    5. Open your newly-created ~/.alsoftrc file into your favorite text editor and locate the line that looks similar to this:
      drivers = alsa,oss,solaris,dsound,winmm,port,pulse,wave
      Make sure it is either commented out by putting a # in front of the line, or edit the line so that it reads
      drivers = pulse
    Note: The version of OpenAL that is in your distro's repositories may not be the most recent version. To see which version you have installed, navigate to /usr/lib/ and search for files that start with "libopenal". There should be two files: One library file, and one symbolic link. If the version number depicted in the library's filename is lower than 1.11.753, then you will need the latest version.

    You will need to build the latest version by following the steps listed here. Basically, download the file provided at that link, extract it somewhere easy for you to find, then follow the steps in the link or in the included README file.

    Note: Depending on your system configuration, you may need additional packages installed. Pay close attention to the output generated while following the build instructions and take corrective action if output indicates missing pulseaudio backend support.

    Once you are done building the latest OpenAL, you will need to replace your existing OpenAL libraries and re-create the symbolic link. To do this:
    sudo rm /usr/lib/libopenal*
    sudo cp where-you-extracted-your-openal-download/build/libopenal.so.1* /usr/lib/
    If all goes well, you should now have a working, up-to-date OpenAL installation. You can test it by issuing the following command in your terminal:
    mplayer -ao openal
    Note for 64-bit users:

    Sorry, but SL still does not support 64-bit gstreamer. You will still need to have OpenAL support disabled and FMOD enabled in order to be able to enjoy parcel music streams in SL. Streaming media (video) is still not possible. If you wish to use Voice in SL, you will still need to install the latest OpenAL following the instructions above, as SLVoice uses OpenAL exclusively.
  27. Marc Adored

    Marc Adored Guest

    Hey Katheryne,

    I posted a blog post awhile back that did exactly what you just said and you have to make sure that if you have a 64bit system you still compile the 32bit version of openal otherwise it wont work. Media streams use gstreamer which is disabled on 64bit systems anyways so for us 32bit users streaming media just isn't an option :( But if you would like the link here it is:


    I havent posted an update to this and my blog post says it doesn't fix the voice issue but the latest openal does fix the SLVoice issues too and all sound works perfectly(with the exception of streaming media because of the gstreamer issue).

    I would have posted this here but I forgot I posted on this forum lol. Hope this is added help to the wonderful post Katheryne just made.
  28. Katheryne

    Katheryne Guest

    Thank you for that, Marc! Your instructions for compiling and installing OpenAL are very clear and easy to follow - more so than mine. :thumbup1: However, you might want to update the wget URL, as there's a newer version available now.

    To clarify something in your post here though: 32-bit users have no issues with streaming media and gstreamer. It is the 64-bit users who cannot use streaming media in SL because of gstreamer incompatibilities. This is an SL problem, as I'm not aware of gstreamer issues with any other application.

    I'm curious to know why you don't get working SLVoice though. Are you on a 64-bit system? There was a bug with the Vivox runtime libraries that required patching to keep SLVoice from segfaulting on 64-bit systems - instructions for that are at the beginning of this thread.
  29. Well, that's news to me. I'm running both Sabayon and Ubuntu, 32 bit versions. I've tried multiple viewers, including LL's main one, Snowglobe, Hippo, Emerald, Imprudence, and probably a few others I've forgotten, under both OSs and under WINE in both OSs. I have never been able to get the audio component of the video stream to work, regardless of whether the source is the traditional youtube or the now acceptable direct links to video files. I have the latest gstreamer and all of the plugins installed. I have talked to every linux user I've encountered in SL and occasionally chatted on the SL linux users group, SLLUG, channel and have never talked to even one who has gotten this to work. I'm not talking about SL audio in general. All of the other audio in SL (music, environment, voice, etc.) can be made to work. Has anyone here gotten the audio component of videos to work under ANY linux system?